| Passwort vergessen?
Sie sind nicht angemeldet.  Anmelden

Sprache auswählen:

myhobby-CNC - Supportforum

Z-Achse überlastet?
 1 2
18.04.19 17:30
smaerkle 
Re: Z-Achse überlastet?

crix:
Ist der Motorstrom korrekt eingestellt?

Nach 'Gehör', ohne Meßgerät. Könnte also eine Fehlerquelle sein.

crix:
Interessant wäre ggf. ein Kreuztausch: Tritt das selbe phänomen mit dem selben treiber auch an einer anderen Achse auf?

Das kann ich mal probieren.


crix:
Bei einem thermischen shutdown eines treibers sollte GRBL davon nichts mitbekommen. Die beiden anderen Achsen solten weiterlaufen und auch im Protokollfenster wäre es nicht zu sehen.

Genau so ist die Symptomatik.

crix:
Das fehlende OK von weiter oben kann man damit nicht erklären...

Hab inzwischen gesehen dass auch an anderen Stellen das OK viel später kommt (trotz 'Single Step' Mode in UGS ... wtf?). Muss also nicht zusammenhängen aber ist schon interessant, dass es gerade an den Stellen auftaucht, wo die Z-Achse dann nicht verfährt ...


crix:
Es sei denn durch eine ausgefallene Achse blockiert die Fräse. Dabei würde dann ggf. ein höherer Strom verbraucht was bei zu schwachem Netzteil dann ggf. zu einem Spannungseinbruch der Versorgung führen könnte. in dem Fall könnte es einen Reset des Arduino bei deutlich unter 5V Stromversorgung geben, dann würden aber alle achsen stehenbleiben und die Bootmeldung von GRBL sollte im Terminal erscheinen...

Das ist es definitiv nicht, X/Y läuft problemlos weiter, grbl geht auch von durchgeführten Steps aus, die Realtime zurückgemeldete Z-Position verändert sich, aber der Nema fährt halt nicht ...

Der Z-Treiber ist ja auch noch einer der beiden mittleren, d.h. der liegt voll im Luftstrom meines Lüfters ...

Würde ein anderes Step-Setting den Treiber-Baustein der entsprechenden Achse entlasten? Bei der Stepper-Frequenz bin ich noch im tiefgrünen Bereich...

Gruß
Stefan

18.04.19 22:18
crix 

Re: Z-Achse überlastet?

In Frage kommt auch noch ein Wackelkontakt an der Enable oder Step Leitung zum Treiber der Z-Achse.
Vielleicht da nochmal nachlöten..

01.05.19 15:48
smaerkle 
Re: Z-Achse überlastet?

So heute lief sie 4 Stunden stabil. Was habe ich geändert:

1. Ströme auf 1,9 A reduziert an allen Treibern (TB67S109 benötigt dzau Vref=0,95 Volt) (War vorher auf 2,1A)
2. Alle Pfostenstecker mit Klebeband fixiert gegen mögliches loswackeln

Danke @Crix, einer von Deinen beiden Tipps war es wohl, ich werde nicht mehr rückwärts ausporobieren welcher


Gruß
Stefan

 1 2
Schutzschaltung   Stromversorgung   zurückgemeldete   Nachkommastellen   Spannungseinbruch   Elektronik-Umhausungs-Bauplan   Stepper-Frequenz   Maximalgeschwindigkeit   Lösungsansätze   zusammenhängen   grbl-Zeichenbegrenzung   Z-Achse   Microstepping   Treiberbaustein   Treiber-Baustein   überlastet   Protokollfenster   Versorgungsspannung   Verfahr-Geschwindigkeit   eingestellt