| Passwort vergessen?
Sie sind nicht angemeldet.  Anmelden

Sprache auswählen:

myhobby-CNC - Supportforum

Spindelsteuerung M3 M5 und Sxxxx funktioniert nicht mehr
 1
16.08.19 17:12
smid 

Spindelsteuerung M3 M5 und Sxxxx funktioniert nicht mehr

Hallo zusammen,

ich habe im Zuge der Inbetriebnahme meiner Shapeoko-Max heute die Spindel in Betrieb genommen. Ohne Last im Leerlauf.
Hat die ersten 15 Minute auch alles geklappt wie es sollte, M3, M5 uns Sxxxx haben wie erwartet funktioniert.

GRBL-Controller Board und 300W Spindel von myhobby-CNC, Board "zwangsbelüftet".

Nach 10 Minuten ließ sich die Spindel aber nicht mehr per M5 ausschalten und läuft nun sofort an, sobald das Board 24V bekommt, auch wenn USB nicht verbunden ist.

Verfahren und Homing geht wie gewohnt.

Nch dem Einschalten meldet GRBL zurück

[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]

Hm, das wäre ja Spindel an, RPM 0%

Tatsächlich läuft die Spindel mit RPM 100%

Egal was ich dann schicke, die Spindel läuft weiter mit 100%, obwohl GRBL die Befehle anzunehmen scheint:

>>> M3
ok
>>> $G
[GC:G0 G54 G17 G21 G90 G94 M3 M9 T0 F0 S0]
ok
>>> M5
ok
>>> $G
[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]
ok
>>> S500
ok
>>> $G
[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S500]
ok
>>> S200
ok
>>> $G
[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S200]

Auch ein $X hat nicht verändert.

Wenn ich das richtig verstanden habe, sollte ja der Arduino Pin 12 (auf dem GRBL-Controller Board entsprechend Pin 26) das PWM Signal für on/off/speed tragen. Der ist bei mir, unabhängig davon, was ich sende, high.

Ich bin etwas ratlos und wäre dankbar für einen Hinweis, was ich noch probieren könnte.

schönen Abend,
Andreas

16.08.19 17:25
crix 

Re: Spindelsteuerung M3 M5 und Sxxxx funktioniert nicht mehr

Es hat mal ein- oder zwei Fälle gegeben in denen der MOSFET über den die Spindel eingeschaltet wird durchlegiert ist und dann einen internen Kurzschluss hat, so dass die Spindel immer 100% läuft.

Du könntest mal bei abgeklemmter Spannungsversorgung und Spindel messen ob es einen kurzschluss zwischen den Spindle Anschlüssen am Rand der Platine bei Q1 gibt zwischen den beiden rechten und den beiden linken.

In dem Fall müsstest Du den Q1 ersetzen, (zum beispiel gegen Q2 tauschen) und Sicherheitshalber noch eine zusätzliche Freilaufdiode einbauen.

Siehe auch:
http://www.myhobby-cnc.de/forum/board/th...ung-4_79_2.html

Gruß
crix

16.08.19 19:24
smid 

Re: Spindelsteuerung M3 M5 und Sxxxx funktioniert nicht mehr

Danke crix,

das war's auch, der Mosfet hatte Durchgang. Hab dann den defekten Q1 gegen Q2 getauscht, siehe da, geht wieder.

Genau ein mal (einschalten). Jetzt ist auch Q2 durch. Grrr.

Den nächsten Versuch dann also mit zusätzlicher Freilaufdiode. Welcher Typ sollte es denn mindestens sein, wenn 1N4007 zu klein dimensioniert ist?


Schönen Abend,
Andreas

17.08.19 14:07
crix 

Re: Spindelsteuerung M3 M5 und Sxxxx funktioniert nicht mehr

Da musst du mal recherchieren.. ich selbst setze das nicht so ein.
Was ich auf die Schnelle gefunden habe wäre dass man idealerweise Shottky Dioden verwende sollte mit einer Spannungsfestigkeit von 5-6x der Normalspannung, also mindestens 6x24V = 144V. Was die an Strom können muss hab ich jetzt erstmal nix gefunden. Von der Hausnummer her würde ich mich mal am Motorstrom orientieren. Das wären bei 300W an 24V dann noch 12A.

18.08.19 10:23
smid 

Re: Spindelsteuerung M3 M5 und Sxxxx funktioniert nicht mehr

Morgen,

es gibt einen passenden Thread auf Roboternetz:
https://www.roboternetz.de/community/thr...teuerte-Motoren.

Ich teste mal und berichte.

VG
Andreas

25.08.19 19:14
smid 

Re: Spindelsteuerung M3 M5 und Sxxxx funktioniert nicht mehr

Ich habe nun direkt zwischen die beiden Motorlitzen eine Freilaufdiode gelötet und seitdem keine Probleme mehr gehabt.
Wahrscheinlich ist das Ding heillos überdimensioniert, aber es funktioniert:
Ultraschnelle Gleichtichterdiode 1000V 3A Typ UF 5408.

VG
Andreas

29.08.19 06:28
Ronald 

Moderator

Re: Spindelsteuerung M3 M5 und Sxxxx funktioniert nicht mehr

Hallo,

freut mich, dass es jetzt funktioniert. Ich muss sagen, zum Glück, hatten die vorherigen Kunden bisher noch nicht so auffällige Problem. Ich auch nicht, daher konnte ich auch vorher nichts beitragen.

Wie crix schon gesagt hat, haben die MOSFETs gegenläufige Dioden eingebaut, wass eigentlich die Probleme nicht aufkommen lassen sollte. Ich kann mir nur vorstellen, dass der Motor als Einzelstück irgend welche Probleme bereitet?!?

Danke, dass Du eine Lösung gefunden hast, die auch für andere helfen könnte.

LG Ronald

 1
Spindelsteuerung   funktioniert   überdimensioniert   Inbetriebnahme   Sicherheitshalber   Spannungsversorgung   Ultraschnelle   recherchieren   Gleichtichterdiode   zwangsbelüftet   Spannungsfestigkeit   eingeschaltet   zusätzlicher   Wahrscheinlich   Normalspannung   Spindel   GRBL-Controller   teuerte-Motoren   dimensioniert   Freilaufdiode