| Passwort vergessen?
Sie sind nicht angemeldet.  Anmelden

Sprache auswählen:

myhobby-CNC - Supportforum

Sporadisch viel zu viele Steps
 1 2
22.07.19 13:07
Whooza 
Sporadisch viel zu viele Steps

Mahlzeit,

seit einiger Zeit spiele ich nun schon mit meiner MAX rum und schon einiges gefräst. Was bisher aber noch nicht so wollte waren die runden Kreise. Damit wollte ich mich gerade beschäftigen als mir ein neues Problem aufgefallen ist, welchem ich mich nun erstmal widmen muss.

Zum Gerät:
Steuerung über GRBL Panel, aber auch Candle etc. ausprobiert.
Version: 1.1f
NEMA23 mit Pullys und Riemen (HTD 3M) aus dem Set
Treiberbausteine: Name? -> Weiss ;-)
Bearbeitungsfläche: 100cm x 60cm
Meanwell 24V DC Netzteil
GRBL-Controllerboard 2.02
Riemen sind ziemlich straff, ich kann X und Y-Riemen ohne Gewalt ca 2cm mittig anheben.
Sie berühren das Aluprofil nicht.


Die Maschine macht prinzipiell was sie soll, jedoch mit Ausnahmen.

Das Problem:

Beim manuellen Bewegen der X-Achse in beliebiger Distanz macht sie sporadisch vieeel zu viele Schritte. Beispiel:
X+10 = 10mm weiter
X-10 = 10mm weiter
X+10 = 80mm weiter mit deutlich höherer Vorschubgeschwindigkeit
X-10 = 80mm weiter mit deutlich höherer Vorschubgeschwindigkeit
X+10 = 80mm weiter mit deutlich höherer Vorschubgeschwindigkeit
nach kurzer Zeit...-
X+10 = 10mm weiter

Das Problem tritt bisher nur auf der X-Achse auf. Die zu großen Sprünge bleiben dann teils für 1-3 Minuten und dann ganz plötzlich verfährt er wieder genau 10mm (+-4 100stel). In der Konsole zeigt er mir auch genau das an was ich möchte: $J=G91G21X-10 F1000 zum Beispiel.

Ich war gerade dabei mit meiner Messuhr die Steps/mm neu zu kalibrieren da ich die Riemen nachgespannt habe. Das Problem ist mir Samstag das erste mal aufgefallen als ich mehrere Stunden Gravuren gefräst habe. Aufgetreten aber nie während den Programmen, nur sporadisch wenn ich das Bearbeitungsstück gewechselt und die Ausgangsposition neu gesucht habe. Aber eben nur sporadisch, nicht immer.

Ich habe mir alle GRBL-Parameter wiederholt angesehen, geschaut ob es eine neue Version gibt und bisher keine Lösung gefunden. Kaum auszumahlen was passiert wenn er mitten im Bearbeitungsmodus plötzlich 20cm statt 3cm fräßt. Ein glück habe ich die Endtaster und Hardlimits eingeschaltet. Aber wäre trotzdem schade ums Holz.


Was mir außerdem aufgefallen ist:
Die Kühlkörper der Treiber werden trotz 24V-Lüfter unfassbar heiß. Den Finger kann ich keine 3 Sekunden drauf halten. Werde auf jeden Fall einen weiteren Lüfter dazu setzen.


Hier ein kurzes Video über meine Dropbox abrufbar: https://www.dropbox.com/s/epjzc0xw867022k/CNC.MOV?dl=0
Konnte leider nicht den Übergang von 10mm-Sprüngen zu den 80mm Sprüngen aufzeichen, Vorführeffekt halt.

Hier meine GRBL Parameter:

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=400.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=1.000
$31=0
$32=0
$100=68.940 (x, step/mm)
$101=68.940 (y, step/mm)
$102=666.000 (z, step/mm)
$110=4000.000 (x max rate, mm/min)
$111=4000.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=20.000 (x accel, mm/sec^2)
$121=25.000 (y accel, mm/sec^2)
$122=8.000 (z accel, mm/sec^2)
$130=600.000 (x max travel, mm)
$131=1000.000 (y max travel, mm)
$132=200.000 (z max travel, mm)


Er verhält sich so als würde der Parameter $100 nicht konstant sein, sondern mitten im Betrieb varieren.

Hat da jemand einen Tipp?

Gruß Alex

Zuletzt bearbeitet am 22.07.19 13:18

Datei-Anhänge
IMG_8961.jpg IMG_8961.jpg (2x)

Mime-Type: image/jpeg, 2.578 kB

IMG_8962.jpg IMG_8962.jpg (1x)

Mime-Type: image/jpeg, 2.660 kB

IMG_8963.jpg IMG_8963.jpg (1x)

Mime-Type: image/jpeg, 2.626 kB

22.07.19 13:17
crix 

Re: Sporadisch viel zu viele Steps

Ich vermute einen Wackelkontakt an den Jumpern für die Microstepping Einstellung für die X-Achse.
Steckt der Jumper richtig?
Ggf mal die Lötstellen prüfen und nachlöten.

22.07.19 13:20
Whooza 
Re: Sporadisch viel zu viele Steps

Ich prüfe es mal, auch wenn ich dafür meinen ganzen Kasten zerlegen muss. Habe nun mehrere Monate problemlos gefräst. Samstag mehrere 40-Minütige Programme durchlaufen lassen. Während den Fräsungen gab es keine Probleme, nur ab und an beim Werkstückwechsel.

Nachtrag: Während ich den Beitrag oben verfasst habe stand die Maschine still und die Treiber konnten vermutlich etwas abkühlen. Und schwupps, wieder die gewünschten 10mm-Schritte bei X+10. So wie es sein soll... Bis zum nächsten Aussetzer.

Zuletzt bearbeitet am 22.07.19 13:22

22.07.19 13:33
Whooza 
Re: Sporadisch viel zu viele Steps

Hier noch ein kurzes Video wie sie sonst arbeitet auf der X-Achse wenn sie keinen Aussetzer hat:
https://www.dropbox.com/s/hj2vrw0ys5yec2...igkeit.MOV?dl=0

29.07.19 13:56
Whooza 
Re: Sporadisch viel zu viele Steps

So, Platine überprüft. Alles gereinigt und teils nochmal nachgelötet. Keine Fehler festzustellen. Neues Gehäuse für den Controller gebaut mit mehr Lüftern und besserer Thermik und was soll ich sagen... Problem besteht weiterhin.

Hier ein Dropbox-Link zu Fotos von der Platine und einem weiteren Video:
https://www.dropbox.com/sh/n1aep0jncbkd9...wrt9LL-jca?dl=0

Besonders im Bereich der Treiber und Jumper kann ich absolut keine Probleme feststellen die dafür sorgen das mitten im Betrieb das Stepping verändert wird. Hinzu kommt noch: Im Gegensatz zum Wiki / der Anleitung stimmten die Einstellungen bei mir absolut nicht. Beim Stepping gemäß Vorgabe bin ich bei 666 Steps/mm für X/Y und ca 1200 Steps/mm für die Z-Achse gelandet. Habe das Stepping damals über die Jumper verändert und bin nun bei 69.6/68.94/666.00 (X/Y/Z). Nicht so wie die glaube 33,33 die im Wiki stehen.

Das Problem mit den heißen Treibern habe ich durch einen zusätzlichen 24V 80mm Lüfter der die geleitete Luft direkt auf die Kühlkörper leitet, gelöst. Selbst bei hoher Belastung werden sie nur noch lauwarm.

Zusätzlich gibt es ein neues Problem. Nach dem Verbinden mit GRBL-Panel ist die Maschine betriebsbereit und wenn ich sie einen Moment nicht manuell bewege, sperrt sie sich und wirft den "error:Line overflow". Laut Recherche geht es um zu lange G-Code-Sequenzen bei zu geringem Speicher. In den Momenten in denen dieser Fehler auftrat habe ich aber nicht gemacht mit dem Controller. Klicke ich auf "Unlock" ohne die Maschine zu bewegen, kam der Fehler wieder.

Nach dem Umbau lief es erst gut für ein paar Minuten und als ich nochmal die X-Achse an der Messuhr kontrollieren wollte fing sie wieder mit den riesen Sprüngen an.

Langsam aber sicher verliere ich die Lust am Fräsen, noch bevor ich richtig angefangen habe.

Vielen Dank schon mal für eure Unterstützung.

Gruß Alex

30.07.19 10:56
crix 

Re: Sporadisch viel zu viele Steps

Hi,

Die Treiber sehen nach den S109ern aus. Die haben eine andere Microstepping Belegung.
In diesem Forumsbeitrag ging es um ähnliche Probleme, dort ist auch eine Microstepping Tabelle für die Treiber verlinkt.
http://www.myhobby-cnc.de/forum/board/th...09-4_124.html#2

An den Speps/mm soll man eigentlich nicht rumkalibrieren. Das lässt sich aus Microstepping, Zahnabstand, Pulley und Motorschritten berechnen und sollte dann so passen.

Die Box sieht ziemlich eng aus, du musst sicherstellen dass da ein ausreichender luftstrom zur Kühlung vorhanden ist.
Rein und auch wieder raus.

Zuletzt bearbeitet am 30.07.19 10:58

30.07.19 14:32
Ronald 

Moderator

Re: Sporadisch viel zu viele Steps

Hallo Whooza,

falls Du noch nicht fündig geworden bist, würde ich Dich um folgendes bitten:

Start die Fehlersuch doch bitte mit der Standardeinstellung der Parameter:



Parameter $30-32 kenne ich noch nicht? Und die Parameter $130-132 sind bei Dir sehr hoch! Das kann klappen, muss aber nicht. Die Kühlkörper werden heiß, weil Du bei $1=255 eingestellt hast! Dadurch ist der Haltestrom auf max. eingestellt. Für die Standardparameter musst Du dann die Jumper so einstellen, dass für die X- und Y-Achse 1/8 Microstepping und für die Z-Achse 1/2 eingestellt sind. Dann müssten auch die Parameter für $100-102 wieder passen! Wenn Du die Parameter gleich hochladen willst, habe ich die Datei hier nochmal angehängt! Starte sie wie eine *.NC-Datei!

Melde Dich dann mit den Ergebnissen!

LG Ronald

P.S. Die Enststopp Einstellungen kannst Du natürlich ändern, wenn das bei Dir bisher alles gut geklappt hat!

Datei-Anhänge
Param_Default.nc.txt Param_Default.nc.txt (3x)

Mime-Type: text/plain, 1 kB

30.07.19 20:40
Whooza 
Re: Sporadisch viel zu viele Steps

Hi, mit den Standardparametern hatte ich die Inbetriebnahme gemacht und mich dann über das Wiki etc. an die Anpassungen gemacht.
Die Parameter 30-32 sind mit Grbl 1.1 dazugekommen. Die Parameter $130-132 sind die Maße der Bearbeitungsfläche, gemäß deinem Wiki sind diese Werte entsprechend anzupassen. Sollen wohl für die Softlimits sein. Zu $1 steht in deinem Wiki die Empfehlung diese auf 255 ms zu stellen wenn man einen Riemenantrieb verwendet.

Die Parameter $100-102 habe ich ein gemessen mit einer Messuhr und exakten Messungen mit Messschieber etc.. Sprich Maschine soll z.Bsp. von Startpunkt auf Y 900mm Weg beschreiten, stoppte aber kurz vorher bereits = Wert minimal erhöhen, fuhr darüber hinaus = Wert verringern.
Solange bis alles zu 100% passt. Nach dem Nachspannen meiner Riemen zum Beispiel musste ich die Werte wieder minimal anpassen da sich das Verhältnis verändert hat. Mit den Standardwerten bekommen ich dann beispielsweise keine Box die genau 100x100mm ist wenn ich das so gemäß CAM wollte, sondern nur so ungefähr eben. Mit den angepassten Werten bin ich bei <+-0,4mm Tolleranz. Außer eben die X-Achse tickt aus... ;-)

Zum Gehäuse:
Das alte war wirklich etwas eng. Das neue im letzten Beitrag zu sehen ist deutlich geräumiger und der 80mm Lüfter pustet kräftig die warme Luft aus dem Gehäuse. Die Abluftlöcher sind so angeordnet, das die Luft einmal durch das Gehäuse muss. Das Ergebnis ist maximal lauwarme Treiber anstelle von kochend heiss.


Habe jetzt mal folgendes getestet:

Jumper auf 1/8 (MS1+2) und 1/2 (MS1) gesteckt (siehe Foto) und die Standardparameter geladen. Ergebnis: Y-Achse funktioniert nicht und gibt nur gruselige Geräusche von sich. Z-Achse verfährt laut erstem Eindruck ziemlich genau 10mm bei 10mm Verfahrweg (noch nicht mit Messuhr getestet) steigt bei zu hohem Tempo aber fiepend aus und die X-Achse verfährt 4,x mm bei gewünschtem Verfahrweg von 10mm. Hinzu kommt, das aufgrund des sofortigen Ablassens der Spannung der Fräser sich beim eigentlichen Endpunkt nochmal knapp 0.15mm bewegt. Das sorgt am Ende natürlich zu Ungenauigkeiten bei jedem Stop der Achsen. Zusätzlich habe ich den Treiber von X quer getauscht mit Z um diesen auszuschließen oder eben festzustellen das der Fehler wandert.

Dann habe ich nun die folgenden Parameter wieder angepasst:
$1=255 Dadurch halten die Motoren die Spannung und bleiben Starr auf der Achse
$21=1 Soll stoppen wenn Endtaster auslösen
$22=1 Homing ermöglichen
$25=400 Empfand 700 als ziemlich schnell für die Endtaster
$100=68.860 anstelle von 33.333 (Stepping passt also dennoch nicht, aber dadurch laut Messuhr auf 0,5/100stel genau bei 10mm Weg)
$101=Y-Achse bewegt sich nicht mehr...
$102=erstmal auf 320 belassen
$112=800 Z-Achse steigt aus bei 1000, siehe Video im Dropbox-Link)
$122=8.000 Z-Achse kann es einfach nicht schneller
$130-132 gem. meinem Bearbeitungsbereich (600x1000)


Ergebnis: Y-Achse funktioniert nicht mehr. Einer der Nema23 Motoren bekommt Spannung und versucht sich zu bewegen. Der andere bekommt ebenfalls Spannung, versucht sich aber garnicht erst zu bewegen und bleibt ganz genau da wo er gerade ist. Dadurch versucht sich die Gantry zu verbiegen... Und ich hab nen Wackler an den Endstops der X-Achse entdeckt. Immer wenn ich den Stecker auf dem Board minimal berührt/gewackelt hab hat er mir den Alarm:1 ausgegeben ohne aber den Endtaster betätigt zu haben. Habe ich nun erstmal abgezogen.

Aber hey, bisher ist die X-Achse noch nicht wieder gesprungen und die Z-Achse auch nicht (dort wo jetzt der Treiber steckt).

Nochmal der Dropbox-Link zu den Fotos/Videos: https://www.dropbox.com/sh/n1aep0jncbkd9...wrt9LL-jca?dl=0

Ich probiere morgen mal weiter, muss mich mal ablenken :-)

Gruß Alex

Zuletzt bearbeitet am 30.07.19 20:41

09.08.19 16:09
Whooza 
Re: Sporadisch viel zu viele Steps

Update:
Habe auf blauen Dunst mal die Treiber-Bausteine quergetauscht und der Fehler wanderte mal mit und mal nicht. Habe nun einfach wahllos zwei Treiber gegen neue ausgetauscht und aktuell scheint wieder alles zu funktionieren. Habe noch nichts gefräst aber wenigstens X/Y und Z achse auf 1/100mm eingemessen. Mal sehen wie es läuft am Wochenende mit weiteren Tests.

10.08.19 23:56
crix 

Re: Sporadisch viel zu viele Steps

Hallo Alex,

ich habe mal die Microsteppingbelegung aus dem Datenblatt für die TB67S109 in's Wiki übernommen.
http://wiki.myhobby-cnc.de/doku.php?id=m...;#microstepping

Demnach hast Du X und Y Achse auf 1/16 konfiguriert. Das ist ziemlich hoch. Da GRBL auf dem Arduino mit der maximalen Schrittfrequenz recht begrenzt ist, konfiguriere mal X und Y Achsen auf 1/8. Für den FYS Treiber (weiss) wäre das

MS1=gesteckt, MS2=offen und MS3=gesteckt für X, Y und E.
Dann müssten die Schritte / mm auch auf 33.333 kommen.

Wie bereits erwähnt sollte über den parameter nicht "kalibriert" werden. Das muss so passen. Wenn es nicht passt, dann Zahnriemenspannung und Laufrollenspannung prüfen!

Gruß
crix

 1 2
Treiber-Bausteine   Standardparameter   Parameter   Sporadisch   [code=generic]$0=10   Jumperbeschreibung   Bearbeitungsmodus   Zahnriemenspannung   Vorschubgeschwindigkeit   Standardparametern   Microstepping   Laufrollenspannung   G-Code-Sequenzen   Bearbeitungsfläche   GRBL-Controllerboard   Microsteppingbelegung   Ausgangsposition   Standardeinstellung   Bearbeitungsstück   Werkstückwechsel