| Passwort vergessen?
Sie sind nicht angemeldet.  Anmelden

Sprache auswählen:

myhobby-CNC - Supportforum

Probleme mit Steuerung TB6600
 1
27.01.19 19:08
W.Pelikan 
Probleme mit Steuerung TB6600

Hallo,

ich habe eine Eigenbaufräse (Holz) mit 3 NEMA 23, die von 3 TB 6600 angesteuert werden. Die Fräse wird von einem Arduino Nano über EstlCam (Version11) gesteuert. Die ersten Fräsversuche von Platinen (ich bib Anfänger) waren durchaus positiv. Beim Fräsen von Namensschildern traten plötzlich Probleme auf: es kam wiederholt zum Stillstand eines Steppers. Mal war es der X-, dann der Z- und mal der Y-Stepper. Die Ursache lag eindeutig bei den Steuereinheiten. Nach einem Stopp liefen die Stepper wieder einwandfrei. Weder die Stepper noch die Steuergeräte hatten höhere Temperatur.

Die anderen beiden Fräser laufen nach dem Stopp munter weiter, da von EstlCam nicht erkannt wird, dass ein Stepper ausgefallen ist. Das Fräsgut ist dann natürlich Schrott, wenn der Z-Stepper stoppte, meistens auch der Fräser.

Meine Frage: hat jemand ähnliche Erfahrungen gemacht oder hat vielleicht jemand eine Ahnung, woran es liegen könnte? Die Steuergeräte sind auf 1600 und eine PK-Current von 3,2 Ampere eingestellt, die Fräsgeschwindigkei habe ich variiert - der Stopp kam bei hoher und auch bei niedriger Geschwindigkeit.

Schon mal vielen Dank für eure Hilfe und Grüße aus dem Süden,

Waldi.

28.01.19 09:01
crix 

Re: Probleme mit Steuerung TB6600

Bei sowas kann ein Video des Problems ganz hilfreich sein. Kannst Du eins machen?

Interessant wäre auch noch die komplette Konfiguration: Microstepping usw.
In Frage kommen auch nicht ganz fest gezogene Pulleys oder sowas..

28.01.19 15:19
W.Pelikan 
Re: Probleme mit Steuerung TB6600

Ein Video ist schwer zu machen, da die Stopps nur sporadisch auftreten. Die Fehlerquellen sind aber zu 100 Prozent die TB 6600. Das konnte ich durch Vertauschen der Stepperanschlüsse eindeutig nachweisen. Pulleys verwende ich nicht, die Stepper gehen direkt an die Spindeln. Das Microstepping habe ich für alle 3 Stepper auf 1600 Pulses/rev eingestellt, die PK-Current auf 3,2 Ampere, was für einen Nema 23 reichen müßte.
Gefräst habe ich kleine ellyptische Namensschilder (ca 10 cm Achsendurchmesser) in 9 mm braune MFD-Platten. Die Ellypsen wurden mit einem 5 mm Fräser ausgefräst, die Schrift mit einem spitzen Gravierfräser, Frästiefe 0,2 mm, gefräst. Also eine Überlastung der Stepper ist eigentlich auszuschließen.
Was ich eher im Verdacht habe sind elektrische Störimpulse von der Fräse (Kress 800) oder dem Netzteil (350 W 36 V 9,7A). Aber wie das herausbringen?

28.01.19 15:34
crix 

Re: Probleme mit Steuerung TB6600

Dann sehe ich folgende mögliche Quellen:
1) Mechanisch: sind die Spindeln über den gesamten Bereich leichtgängig?
ist die Verbindung zwischen Motor und Spindel fest und entkoppelt?

2) TB6600 ist eine Überhitzung ausgeschlossen?
Ist der Kontakt zwischen Chip und Kühlkörper einwandfrei (Wärmeleitpaste)
Ist es tatsächlich ein TB6600 Chip der 3,2A ohne Überitzung treiben kann?
(Hintergrund: billige China TB6600 aus der Bucht sind teilweise keine TB6600 IC's und haben teilweise keine ordentliche Kühlung oder fehlenden thermischen Kontakt)

3) Elektrisch
Ist die ENABLE Leitung korrekt beschaltet (3/4 TB6600 an einem Enable Ausgang vom Arduino?)
sind die Signale (ENABLE, DIR, STEP) ausreichend stark um die Optokoppler am Eingang der TB6600 zuverlässig zu schalten?

4) Störungen
Endschalter Leitungen können (wenn sie nicht abgeschirmt sind) Störungen vom Motor einfangen, dann würde aber eher die komplette Fräse abschalten. In dem Fall können Kondensatoren helfen (Siehe Wiki)

Gruß
crix

28.01.19 16:59
W.Pelikan 
Re: Probleme mit Steuerung TB6600

Hallo Crix,

vielen Dank für deine ausführliche Analyse. Ich hab gleich mal einen der "TB 6600" geöffnet. Dein Verdacht hat sich bestätigt, es ist kein TB6600 sondern ein S109 AF Treiber IC eingebaut. Das schafft angeblich bis zu 4 Ampere. Aber leider ist der mechanische Aufbau absolut unprofessionell. Die Platine ist ordentlich gearbeitet, aber zwischen IC und Kühlkörper ist ein Zwischenraum von 4,5 mm, der durch ein 3,5 mm Alublechstück ausgeglichen wird. Der fehlende Millimeter wird durch eine Wärmeleitfolie und jede Menge Wärmeleitpaste überbrückt. Dass es dabei zu einer Überhitzung des IC's kommt ist klar. Ja, da werde ich mal die Teilchen aus Chinesien austauschen gegen solide Ware. Sparen lohnt sich also nicht immer!

Nochmals vielen Dank für deine Hilfe und ein Servus aus dem Chiemgau,
Waldi

28.01.19 18:14
crix 

Re: Probleme mit Steuerung TB6600

Genau von den Teilen hab ich auch welche rumliegen ;-)

Bis Du vernünftige Treiber hast, kannst Du den Strom auf 2A reduzieren (meine Nema23 laufen damit) und die Kühlung optimieren. Damit sollte die Fräse dann auch durchlaufen.

28.01.19 18:22
crix 

Re: Probleme mit Steuerung TB6600

Vielleicht sind die neuen Treiber von Ronald eine Option: http://shop.myhobby-cnc.de/bauteile/elek...driver-tb67s109

29.01.19 16:21
W.Pelikan 
Re: Probleme mit Steuerung TB6600

Das mit der Stromreduzierung hab ich mal gemacht. Bis jetzt klappt es auch recht gut. Ich habe auch die Alu-Zwischenbeläge gegen solche ausgetauscht, die direkten Kontakt mit Chip und Kühlkörper herstellen. Die Kühlung wird dadurch sicher besser. Aber eine dauerhafte Lösung ist das nicht. Ein Chip gehört direkt auf einen Kühlkörper und nicht durch Zwischenbeläge. Das ist deine Grundregel in der Elektronik. Danke für den Link, die Treiber von Ronald werde ich mal im Auge behalten.

30.01.19 09:53
crix 

Re: Probleme mit Steuerung TB6600

Bei den Chinakrachern muss man damit rechnen auf Designfehler zu stossen und diese dann ggf. selbst korrigieren. Wenn man dazu bereit ist, kann man da durchaus Schnäppchen machen ;-)
Wir hatten hier auch schon ein Netzteil das durch ein ungeschickt montiertes internes Kühlblech einen Schnluss zwischen V+ und Gehäuse aufwies.

Es gibt auch im professionelle Einsatz Fälle in denen größere Abstände zwischen Chip und Gehäuse/Kühler auftreten. Diese werden aber mit einem dickeren Wärmepad überbrückt dass der Aufgabe gewachsen ist.

Zuletzt bearbeitet am 30.01.19 10:04

 1
Wärmeleitfolie   Eigenbaufräse   Steuerung   Zwischenbeläge   unprofessionell   Probleme   Geschwindigkeit   driver-tb67s109   Kühlkörper   Steuereinheiten   Wärmeleitpaste   Fräsgeschwindigkei   Namensschildern   Stromreduzierung   auszuschließen   Achsendurchmesser   Alu-Zwischenbeläge   Gravierfräser   Stepperanschlüsse   Steuergeräte