| Passwort vergessen?
Sie sind nicht angemeldet.  Anmelden

Sprache auswählen:

myhobby-CNC - Supportforum

Probleme mit dem GRBL-Board
 1
05.08.18 16:36
Xatrix97 

Probleme mit dem GRBL-Board

Hallo liebe Mitcncler,

ich habe mir vor kurzem die V2.02 des GRBL-Boards als ersatzteil geholt.
Damit haben aber leider die Probleme begonnen... Erst wollte die Estlcam-Steuerung nicht.
Nach kurzem E-mailverkehr kam heraus, dass es sich auf dem Neuen Board nicht mehr um den ATmega328P sondern um seinen Nachfolger den ATmega328PB handelt, wessen Signatur noch nicht von Estlcam unterstützt wird. Dies soll jedoch im nächsten Update geändert werden. Also heißt es warten, da ich aber noch ein paar Projekte habe wollte ich wieder die normale GRBL1.1 Version aufspielen was auch klappte.

Nun zum aktuellen Problem: Im Seriellen Monitor kommt auf den (Laut GRBL WIKI) 115200 Baud nur mist raus, auf 57600 Baud kann man wenigstens einigermaßen erkennen was gemeint ist. Übrigens, die verwendeten .hex Files funktionieren alle samt auf einem Arduino Nano.

Nun ist die Frage, woher kommt das? Und vor allem wie bekomme ich das in den Griff?

Im Anhang gibt es noch Bilder davon.
Ich hoffe ihr könnt mir bei meinem Problem helfen

MfG
Thomas

Datei-Anhänge
cnc.PNG cnc.PNG (6x)

Mime-Type: image/png, 9 kB

cnc2.PNG cnc2.PNG (5x)

Mime-Type: image/png, 23 kB

07.08.18 00:24
crix 

Re: Probleme mit dem GRBL-Board

Ist das verwendete grbl 1.1 hex file für den 328pb geeignet?
Sind die Fuses (Takt!) des Atmeg korrekt gesetzt?

07.08.18 11:32
Xatrix97 

Re: Probleme mit dem GRBL-Board

Gute Frage... ich habe einfach das von der GRBL GitHub Seite drauf gespielt, da es heißt der PB ist P kompatibel.
Ich hab ehrlich gesagt keine Ahnung wie man Fuses richtig einstellt.

 1
aktuellen   verwendete   unterstützt   aufspielen   kompatibel   einigermaßen   GRBL-Board   Estlcam-Steuerung   Übrigens   Seriellen   einstellt   verwendeten   funktionieren   Nachfolger   Probleme   E-mailverkehr   wenigstens   GRBL-Boards   ersatzteil   ATmega328