| Passwort vergessen?
Sie sind nicht angemeldet.  Anmelden

Sprache auswählen:

myhobby-CNC - Supportforum

GRBL-NANO-Board funktioniert nicht so wie es soll
 1 2 3
10.01.18 00:41
Totzauer 
Re: GRBL-NANO-Board funktioniert nicht so wie es soll

ich denk das die dann immer noch nur in die eine richtung laufen
also wenn ich auf der bildschirmschaltfläche nach oben oder nach unten drücke laufen sie immer nur in eine richtung.
kühlkörper kann ich morgen gern mal drauf machen aber ich glaub nicht das das problem löst.

sind ja vier kabel pro motor blau rot für eine richtung und grün/schwarz in die andere richtung.
mir kommt es so vor als würde nur ein kabelpärchen angesteuert. zb. blau rot wenn ich die stecker drehe also grün/schwarz dann fährt der motor schon in die andere richtung aber halt auch wieder wenn ich den steuerbefehl in die andere richtung gebe

10.01.18 09:01
Ronald 

Moderator

Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Hallo,

ich kann mich nur an eine Situation erinnern, in der die Motoren auch bei mir immer nur in eine Richtung gelaufen sind. Da hatte ich einen G-Code erzeugt, der nicht mit dem richtigen Treiberadapter für "GRBL" generiert wurde. Dann werden teilweise bei der G-Code Generierung Befehle erzeugt, die GRBL nicht richtig interpretieren kann. Ein Minus als Vorzeichen wird dann einfach ignoriert.

Womit hast Du den G-Code erstellt? Kannst Du den G-Code hier mal posten, ob eine normale GRBL v0.9 Firmware den überhaupt interpretieren kann?

LG Ronald

Zuletzt bearbeitet am 10.01.18 09:02

10.01.18 09:17
crix 

Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Die 4 Kabel zum Motor werden immer benötigt. Die Richtung wird über das DIR Signal an den Treiber gegeben. Wenn die Verbindung nicht in Ordnung ist, dann könnte es zu dem Phänomen kommen.

Meine estcam einstellungen sind so:

Damit funktioniert meine ShapeOko-Max (setze allerdings die TB6560 Treiber ein).

Datei-Anhänge
EstlcamSettings.jpg EstlcamSettings.jpg (6x)

Mime-Type: image/jpeg, 262 kB

10.01.18 10:10
Totzauer 
Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Die Verbindung ist ok, hab nochmal alles durchgeklingelt.
ich hab die Befürchtung das das Signal zwar raus geht aber nicht mit dem richtigen Befehl.

Ich benutze estlcam und hab noch nichts fräsen können also auch noch keinen g-code erstellt.
Die Funktionen lassen sich über estlcam in der nutzeroberfläche ja schön testen und ich wollt einfach nur die verschiedenen achsen fahren um zu sehen ob alles passt und um die Endschalter zu testen.

ich hab die Firmware GRBL 0.9 nicht drauf sondern den arduino nano über estlcam programmiert
Kristian Knüll der Herausgeber von estlcam meinte, das er keine Erfahrung mit dem board von myhobby-cnc hat aber mit der grbl Einstellung in estlcam eigentlich alles ordnungsgemäß laufen sollte.

@crix
Danke, ich wied mal Deine Einstellungen testen und bericht erstatten

ich wird heut Abend nochmal alles kontrollieren die Leitungen und ströme überprüfen und wenn ich nicht weiter komme muss ich das board leider erst mal zum Ronald zurück zum überprüfen schicken.

ich hab auch schon mal überlegt ob ich mir das GRBL-Controller-Board für 39€ bestelle und teste ob es damit geht. crix hast du damit Erfahrung?

10.01.18 10:39
crix 

Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Ich setzte den Arduino Uno ein, zunächst noch mit dem GBRL Shield inzwiscen wegen der Umrüstung auf TB6560 nur noch der Arduino Uno. Ich habe weder mit dem GRBL Controler Board noch mit dem Nano Board Erfahrungen.

Das nano Board hat Ronald entwickelt weil es es für Leute mit wenig Erfahrung in Elektronik einfacher zu handhaben ist, da man den Arduino einfach tauschen kann. Beim GRBL Controler Board ist alles integriert, bei einem Defekt muss man dann einiges an Know How haben oder das ganze Board tauschen.

Du könntest zum Einkreisen des Fehlers folgendes machen:
Arduino in Estlcam zurückprogrammieren und versuchen Mit GRBL Controler oder SerialComCNC etc. die Achsen zu verfahren, so könntest Du ausschliessen daß es an estlcam liegt.
GRBL Einstellungen (Ausschliesslich per $$ befehle und nicht über die Configmaske von GRBL Controler) vorher prüfen. (Ist im Wiki dokumentiert)
Dann z.B. manuell folgende kommandos absetzen:

F100
G91
G1 X 10
G1 X-10
G1 Z 5
G1 Z -5
G1 Y 10
G1 Y -10

Dann sollten alle Achsen mal in jede Richtung gefahren sein.
Wenn Du mit einem Multimeter am Arduino die DIR Signale misst, sollte sich der Pegel (0V oder 5V) je nach Richtung ändern.
Also bei einem G1 X10 kommando sollte der pegel von DIR X während der Bewegung anders sein als bei G1 X-10.

Dann mal messen ob das auch am X Treiber Eingang so ankommt. Wenn der Pegel sich nicht ändert, ggf. mal den Treiber abziehen und dann messen.

Und mach mal hochauflösende Foto's von dem NANO Board von oben und von unten, wo man sieht wie der Arduino eingesteckt ist und wie die Lötstellen aussehen.

Welche Spannung und Leistung hat das Netzteil was du verwendest?

Zuletzt bearbeitet am 10.01.18 10:44

10.01.18 10:39
Ronald 

Moderator

Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Hallo,

also ich kann nur sagen, dass ich bisher ca. 300 GRBL-Controller-Boards und ca. 100 GRBL-NANO-Boards verkauft habe. Wenn die nicht alle in einer Schublade sind, dann gehe ich davon aus, dass diese produktiv im Einsatz sind, oder zumindest schon mal gelaufen sind. Wenn nicht hätten sich die Kunden bei mir schon gemeldet.

Ich selber habe die Boards ja über mehrere Prototypen hinweg entwickelt, und habe selber beide Boards bei mir im Einsatz. Mit der GRBL-Version 0.8, 0.9 und 1.1 sind die Boards getestet und haben, zumindest bei mir, funktioniert. ESTLCam und deren eigene Firmware kenne ich selber zu wenig, gehe aber nicht davon aus, dass hier wesentliche Änderungen zur GRBL-Version sind. Ich kenne nur Ältere Versionen von ESTLCam, bei denen zwei Firmware Versionen optional mögliche waren. Entweder original GRBL oder eben die eigene von ESTLCam. Bei der ESTLCam Version war damals die Pinbelegung eine andere als bei GRBL.

Leider kann ich nicht für jede erdenkliche Kombination von möglichen Firmware-Varianten und PC-Software Programm die es im Internet gibt Unterstützung leisten. Was ich unterstütze ist z.Z. die originale GRBL-Firmware Linie von Github und die PC-Software "GRBL-Controller" und "Candle". Weiterhin noch die Programmierung mit "XLoader". Alles andere liegt in der Hand des Anwenders.

Ich hoffe Ihr könnt mich da verstehen.

LG Ronald

10.01.18 10:47
crix 

Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Was mir grad noch einfällt. Estlcam hatte zumindest in den früheren Versionen keine Unterstützung für das ENABLE Signal vorgesehen.
Inzwischen kann man da wohl das Schrittmotor Aktivierungssignal invertieren. Ggf. das mal ausprobieren.

Aber wie gesagt. Ich würde dazu raten das System zuerst mit GRBL in Betrieb zu nehmen und zu testen. Wenn dann alles geht wie es soll, ggf. auf andere Software wechseln. Dann ist zumindest klar dass die Hardware soweit funktioniert.

10.01.18 10:49
crix 

Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Eine Weitere Fehlerquelle sind die Endschalter.
Hast Du die verbaut?
Es kann sein dass es da zu übersprechen kommt und die Maschine einen falschen Endanschlag erkennt. Ich weiß nicht wie Estlcam da reagiert, unter GRBL sieht man das an einer entsprechenden Meldung.
Da helfen dann ggf. geschirmte Kabel und Entstörkondensatoren wie im Wiki beschrieben.

10.01.18 10:51
Ronald 

Moderator

Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Das NANO-Board hat die Entstörkondensatoren bereits auf dem Board verlötet!

LG Ronald

10.01.18 10:54
FoodFighter 
Re: GRBL-NANO-Board funktioniert nicht so wie es soll

Hallo,
Prinzipiell gibt es von der Belegung und Ansteuerung her m.E. keinen nennenswerten Unterschied zwischen den Boards - m.E. geht's nur um den Formfaktor bzw. darum, dass beim Nano-Board der Arduino Nano als Prozessor leicht tauschbar wäre.
Was ich damit sagen will: Wenn das Eine Board nicht funktioniert, tut es das andere sehr wahrscheinlich auch nicht.
Der Unterschied wäre Arduino UNO zu Nano ... was der Estlcam Software aber egal sein soll bei (korrekter Einstellung).

Hast du die Estlcam-Software einfach nochmal drüber geflasht? vielleicht ging beim flashen was schief?

Ausm Bauch raus würde ich vermuten, dass deine Treiber einen weg haben...das geht u.U. sehr schnell.

Vom Grundsatz her erinnert mich dein Problem nämlich sehr an einen Beitrag hier im Forum, wo jemand die Treiber erst falsch herum aufgesteckt und damit gegrillt hatte (dazu müssen sie nicht lange falsch herum gesteckt sein).
Aus eigener Erfahrung kann ich das bestätigen, bei meinen ersten Gehversuchen mit einer günstigen GRBL-China-CNC habe ich den gleichen Fehler gemacht und damit die Treiber gekillt.
Das Resultat war wie du es auch beschreibst, die Motoren fuhren nur in eine Richtung und das auch nur, wenn sie Lust dazu hatten.
(Hat also wenigstens den DIR-Eingang vom Treiber gegrillt...kein Wunder, um 180° versetzt liegt der auf 24V vom Netzteil)

Was die Treiber auch schnell grillt ist deren Betrieb ohne angeschlossenen Motor. Gerade dann wenn du keine Kühlkörper verklebt hast und erst recht, wenn du ESTLCAM nutzt, weil hier standardmäßig ab Controller-Start alle Motoren voll bestromt werden, damit sich die Achsen nicht mehr verschieben lassen - mit den Standard-GRBL-Einstellungen auf meinem GRBL-Controller-Board waren das glaube ich immer nur 25ms (Step-Idle delay=25)...da wäre die Überlebenschance schon deutlich größer.

Bist du dir also sicher, dass die Treiber selbst in Ordnung sind? Hättest du evtl. Ersatz zum testen in Reichweite?
Weiterhin könntest du auch messen, ob das DIR-Signal am Treiber überhaupt ankommt

Vielleicht wäre es auch grundlegend erstmal sinnvoll die Fräse mit GRBL komplett zum laufen zu kriegen um sicher zu sein, dass alles so läuft, wie es laufen sollte, bevor du auf Alternativen (Estlcam) ausweichst.

Gruß Markus

 1 2 3
Einstellungen   Entstörkondensatoren   GRBL-NANO-Board   richtung   Firmware-Varianten   nutzeroberfläche   zurückprogrammieren   Wicklungsströmen   Überlebenschance   Standard-GRBL-Einstellungen   estlcam   Aktivierungssignal   Kühlkörper   Treiber   GRBL-Controller-Boards   Wärmeübertragung   bildschirmschaltfläche   funktioniert   GRBL-Controller-Board   Arduino